[graph-tool-tickets] [graph-tool] Ticket #122: graph_tool cannot be imported in Python3

graph-tool webmaster at skewed.de
Tue Dec 18 01:30:48 UTC 2012


#122: graph_tool cannot be imported in Python3
new defect
---------------------------------------------------------------------
Reporter: muellner at math.stanford.edu
Owner: tiago peixoto
Priority: major
Milestone: (None)
---------------------------------------------------------------------
See the following error message on Arch Linux

{{{
Python 3.3.0 (default, Dec 12 2012, 07:38:12) 
[GCC 4.7.2] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import graph_tool
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python3.3/site-packages/graph_tool/__init__.py", line 98, in <module>
    from . import io  # sets up libcore io routines
ImportError: cannot import name io
>>> 
}}}

Is this related to [http://stackoverflow.com/questions/8030264/relative-import-problems-in-python-3]?



--
Ticket URL: <URL:http://graph-tool.skewed.de/ticket/122>
graph-tool <URL:http://graph-tool.skewed.de/>
An efficient python module for graph analysis and manipulation.


More information about the graph-tool-tickets mailing list