[graph-tool-tickets] [graph-tool] Ticket #146: graph-tool 2.2.26 doesn't compile with "clang-3.3 -stdlib=libc++"

graph-tool webmaster at skewed.de
Wed Dec 4 09:57:28 UTC 2013


#146: graph-tool 2.2.26 doesn't compile with "clang-3.3 -stdlib=libc++"
closed defect
---------------------------------------------------------------------
Reporter: Mark.Moll at gmail.com
Owner: tiago peixoto
Priority: normal
Milestone: 2.2

---------------------------------------------------------------------
Comment (by tiago peixoto):

I haven't seen this issue before, and I can't reproduce it on my system.

The symbol which is not being found belongs to cairomm, and corresponds to a public and documented function:

http://cairographics.org/documentation/cairomm/reference/classCairo_1_1Context.html#acb1da5f3949195f76424e11be923fbfd

I don't understand why it is undefined. But it seems likely to be a linking problem....
--
Ticket URL: <URL:http://graph-tool.skewed.de/ticket/146>
graph-tool <URL:http://graph-tool.skewed.de>
An efficient python module for graph analysis and manipulation.


More information about the graph-tool-tickets mailing list