[graph-tool-tickets] [graph-tool] Ticket #146: graph-tool 2.2.26 doesn't compile with "clang-3.3 -stdlib=libc++"

graph-tool webmaster at skewed.de
Thu Jun 26 13:02:34 UTC 2014


#146: graph-tool 2.2.26 doesn't compile with "clang-3.3 -stdlib=libc++"
closed defect
---------------------------------------------------------------------
Reporter: Mark.Moll at gmail.com
Owner: tiago peixoto
Priority: normal
Milestone: 2.2

---------------------------------------------------------------------
Comment (by Reem Mokhtar <reem.mokhtar at gmail.com>):

Replying to [comment:30 anonymous]:
> Thanks for the attention.  I will test MacPorts on a clean 10.8 VM and homebrew on 10.9 and let you know the results.


Hi everyone,

Has anyone been able to resolve this issue? I'm getting the same exact problem as in the build.log with MacPorts (here's a sample output):

{{{
Macports_sources_rsync.macports.org_release_tarballs_ports_python_py-graph-tool/py27-graph-tool/work/graph-tool-2.2.31/src/graph/centrality'
  CXX      graph_trust_transitivity.lo
warning: unknown warning option '-Wno-unused-local-typedefs' [-Wunknown-warning-option]
In file included from graph_trust_transitivity.cc:20:
In file included from /opt/local/include/boost/python.hpp:49:
/opt/local/include/boost/python/opaque_pointer_converter.hpp:172:1: warning: missing field 'tp_version_tag' initializer [-Wmissing-field-initializers]
};
^
}}}

--
Ticket URL: <URL:http://graph-tool.skewed.de/ticket/146>
graph-tool <URL:http://graph-tool.skewed.de>
An efficient python module for graph analysis and manipulation.


More information about the graph-tool-tickets mailing list