[graph-tool] (no subject)

g.venkatasubramaniyan at gmail.com g.venkatasubramaniyan at gmail.com
Sun Jul 1 23:52:48 CEST 2012


I noticed that the temp file( ccwxyz.s) getting bigger and bigger  before 
shooting this error.
So i did a "make -n" in the directory were did this error is reported to 
get the exact compilation syntax and hand created the .lo file myself 
(maually) for that file alone.

After that I was able to proceed with compilation successfully and able to 
do examples. seems to a problem with the tools libtool, etc ...
May be you can also try that way.


On Thursday, June 14, 2012 5:59:11 PM UTC+5:30, 任强 wrote:
>
> HI everyone!
>   I have tried to install graph_tool by compiling source code.But for many 
> times , it reports:
>               virtual memory exhausted: Cannot allocate memory
>   My PC has a 4G main memory and Intel i5 CPU.I thought 4G is enough.
>
>   Then I tried to install by apt-get, and came up with a problem.
>   I have already installed these library before, and versions are right. 
>
> graph-tool : Depends: libboost-iostreams1.42.0 (>= 1.42.0-1) but it is not 
> installable
>               Depends: libboost-python1.42.0 (>= 1.42.0-1) but it is not 
> installable
>               Depends: libboost-regex1.42.0 (>= 1.42.0-1) but it is not 
> installable
>               Depends: libcgal5 but it is not installable
>               Depends: libpython2.6 (>= 2.6) but it is not installable
>               Depends: libboost1.42-dev but it is not installable
>
>   Can anyone help me ? 
>   By the way,how to use the public key ? 
>   I have tried "apt-key add signature.asc",but it reports: 
>               gpg: no valid OpenPGP data found.
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.skewed.de/pipermail/graph-tool/attachments/20120701/8c3e4ffd/attachment.htm>


More information about the graph-tool mailing list