[graph-tool] Installing graph-tool using pip

Peng Yu pengyu.ut at gmail.com
Fri May 4 18:36:14 CEST 2012


On Fri, May 4, 2012 at 11:23 AM, Tiago de Paula Peixoto <tiago at skewed.de> wrote:
> On 05/04/2012 06:04 PM, Peng Yu wrote:
>> Hi,
>>
>> I don't see a way to install graph-tool using pip. Port on Mac OS X is
>> not updated as frequently as pip. I'd recommend adding a way to
>> install graph-tool using pip. Right now, I see the following error.
>
> Neither pip nor easy_install are supported. Huge portions of graph-tool
> are implemented in C++ and thus require compilation. Although it is
> possible to use python's setuptools to compile packages in C/C++ as well
> (numpy and scipy do this), I find that autotools provides a much more
> comfortable and reliable approach, which is more likely to work in
> different environments. I feel that porting things to setuptools would
> be quite a pain.

For Mac, is it possible to make a dmg for installation? (I don't have
any experience on making a dmg package). But this could help potential
users who want avoid compiling the package themselves (the requirement
on gcc 4.4 can be a deal breaker).

-- 
Regards,
Peng



More information about the graph-tool mailing list