[graph-tool] from graph_tool.all import * gives ImportError

vineesh vs shopping_vineeshvs at outlook.com
Tue Jun 28 07:38:03 CEST 2016


I tried the following command in Python and ipython prompt (2.7 version)



---------------------------------------------------------------------------
In [1]: from graph_tool.all import *
---------------------------------------------------------------------------



Its giving the following error. How can we solve it?


---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-1-100bbe2bc9d9> in <module>()
----> 1 from graph_tool.all import *

/usr/lib/python2.7/dist-packages/graph_tool/__init__.py in <module>()
    103 
    104 from .dl_import import *
--> 105 dl_import("from . import libgraph_tool_core as libcore")
    106 __version__ = libcore.mod_info().version
    107 

/usr/lib/python2.7/dist-packages/graph_tool/dl_import.pyc in dl_import(import_expr)
     55 
     56     try:
---> 57         exec(import_expr, local_dict, global_dict)
     58     finally:
     59         sys.setdlopenflags(orig_dlopen_flags)  # reset it to normal case to

<string> in <module>()

ImportError: /usr/lib/python2.7/dist-packages/graph_tool/libgraph_tool_core.so: undefined symbol: _ZN5boost9iostreams4zlib6finishE
---------------------------------------------------------------------------



Thanks
 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.skewed.de/pipermail/graph-tool/attachments/20160628/5483f022/attachment.htm>


More information about the graph-tool mailing list