[graph-tool] Numpy 1.11 version gives error during 'make' of graph-tool

Tiago de Paula Peixoto tiago at skewed.de
Tue Jun 28 10:33:19 CEST 2016


On 28.06.2016 09:07, vineesh vs wrote:
> *The version was 1.60

Surely you mean version 1.6, not 1.60. But as stated in the website, the
minimum required Numpy version is 1.7.

> *I installed the numpy using command line
>
> sudo apt-get install python-numpy

This suggest that you are using a Debian based distribution. If this is
either Ubuntu or Debian itself, I suggest you use the pre-compiled
packages in the website, since they are easier to install than
compilation by hand.

In any case, even after I explicitly asked, you haven't yet given any
precise information about your system, which makes troubleshooting
difficult.

> I removed the Python 1.60 which comes by default while doing _sudo
> apt-get install python-numpy_ and installed Python 1.11.1 from
> Sourceforge and then tried to do _make_ for graph-tool. Getting the
> following error

Surely you mean Numpy, not 'Python'.

In any case the error below:

> ./../numpy_bind.hh:30:31: fatal error: numpy/arrayobject.h: No such file or directory

obviously means that you haven't passed the path of your numpy
installation to ./configure, or that you haven't installed numpy
correctly.

As I said before, in order for us to be able to help you, you need to
give us more information. We need to know, for instance, how you
installed numpy, what is the full output of the configure script, what
are the contents of the config.log file, etc.

Rest assured that none of the issues you are encountering are problems
with graph-tool itself. You just need to install its dependencies
properly.

If you are uncomfortable with learning how to do this, I would like to
recommend again the binary packages. That's why they exist.

Best,
Tiago

--
Tiago de Paula Peixoto <tiago at skewed.de>

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <https://lists.skewed.de/pipermail/graph-tool/attachments/20160628/f2288a8a/attachment.asc>


More information about the graph-tool mailing list