[graph-tool] Numpy 1.11 version gives error during 'make' of graph-tool

Tiago de Paula Peixoto tiago at skewed.de
Tue Jun 28 14:49:20 CEST 2016


On 28.06.2016 13:07, vineeshvs wrote:
>> minimum required Numpy version is 1.7
>
> Now I have installed version 1.7.1 from sourceforge.
> Downloaded the .tar.gz file from folder extracted it and installed the
> package using the command: python setup.py install
> Verified the version in Python using: import numpy; numpy.version.version

You don't need to install this particular version. This is only the
_minimum_ version. Version 1.11 will work just fine.

> OS type: 64-bit, Ubuntu 12.04 (precise)

This is fairly outdated. Even if you fix the numpy problem, you probably
will run in other problems with Ubuntu 12.04. By far the simplest
approach would be to upgrade to a more recent Ubuntu version and use the
Ubuntu packages available for graph-tool.

>
> Used the following configure command (including the path to numpy obtained
> from the previous step
> ./configure CPPFLAGS="-I/usr/include/python2.7"
>
> That was a mistake. The command used was
> ./configure CPPFLAGS="-I/usr/local/lib/python2.7"

Both are incorrect. In fact, it should not be necessary to pass
anything if numpy was properly installed. Please post the output of:

    import numpy
    print numpy.get_include()

when run from the Python interpreter.

Also, please post the _full_ output of the ./configure command as well
as the entire content of the config.log file.

Best,
Tiago

-- 
Tiago de Paula Peixoto <tiago at skewed.de>

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <https://lists.skewed.de/pipermail/graph-tool/attachments/20160628/12888f27/attachment.asc>


More information about the graph-tool mailing list