[graph-tool] Graph-tool configure error: Boost::Iostreams library is available but no usable boost::iostreams is found

Frank Takes ftakes at liacs.nl
Sun May 29 10:11:02 CEST 2016


Assuming you installed boost yourself cf.
http://www.boost.org/doc/libs/1_61_0/more/getting_started/unix-variants.html,
after running bootstrap.sh, you would run

    ./b2 install

This is not enough for graph-tool, and to install iostreams as well, you
would run

    ./b2 install --with-iostreams

When installing graph-tool on CentOS 7, after this I also had to install
--with-coroutine, and a few more (which I do not remember).

The above answer is somewhat generic, but seeing that you use Ubuntu, it
may be that your package manager allows you to do this more easily, for
example using a command like

    sudo apt-get install libboost-all-dev

Good luck!


Frank


2016-05-29 6:58 GMT+02:00 Bretsky <bretskyselby99 at gmail.com>:

> Disclaimer: I am a Linux noob and I don't know anything about C++.
>
> I'm trying to configure graph-tool on Ubuntu 16.04 with Python 3.5.1. I
> have
> installed all of the prerequisites, and I ran  Everything worked up until I
> got this error:
>
> I tried using the fix suggested  here
> <
> http://main-discussion-list-for-the-graph-tool-project.982480.n3.nabble.com/Compiling-v1-13-dev-configure-error-No-usable-boost-iostreams-found-td4026438.html#a4026443
> >
> , but I got the same error when I ran
> which is the path I got from my Boost installation
>
>
> I am not sure how to fix this and would really appreciate if someone who
> knows more about Linux and graph-tool could help me.
>
>
>
> --
> View this message in context:
> http://main-discussion-list-for-the-graph-tool-project.982480.n3.nabble.com/Graph-tool-configure-error-Boost-Iostreams-library-is-available-but-no-usable-boost-iostreams-is-foud-tp4026585.html
> Sent from the Main discussion list for the graph-tool project mailing list
> archive at Nabble.com.
> _______________________________________________
> graph-tool mailing list
> graph-tool at skewed.de
> https://lists.skewed.de/mailman/listinfo/graph-tool
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.skewed.de/pipermail/graph-tool/attachments/20160529/d53daf47/attachment.htm>


More information about the graph-tool mailing list