[graph-tool] Graph-tool configure error: Boost::Iostreams library is available but no usable boost::iostreams is found

Tiago de Paula Peixoto tiago at skewed.de
Sun May 29 15:13:14 CEST 2016


On 29.05.2016 13:58, Bretsky wrote:
> Disclaimer: I am a Linux noob and I don't know anything about C++.

I think the easiest for you would be to use the Ubuntu packages
available in the website.

> I'm trying to configure graph-tool on Ubuntu 16.04 with Python 3.5.1. I have
> installed all of the prerequisites, and I ran  Everything worked up until I
> got this error:
>
> I tried using the fix suggested  here
> <http://main-discussion-list-for-the-graph-tool-project.982480.n3.nabble.com/Compiling-v1-13-dev-configure-error-No-usable-boost-iostreams-found-td4026438.html#a4026443>
> , but I got the same error when I ran
> which is the path I got from my Boost installation
>
>
> I am not sure how to fix this and would really appreciate if someone who
> knows more about Linux and graph-tool could help me.

If you want help with the compilation you need to give more precise
information, including the options you passed to configure, the whole
output as well as the full contents of the config.log file.

Best,
Tiago

-- 
Tiago de Paula Peixoto <tiago at skewed.de>



More information about the graph-tool mailing list